Aller au contenu

erreur 400


saida
 Share

Messages recommandés

bonjour.

lorsque je me connecte au site avec mon Smartphone et que je clic sur certains des liens jai une page : 400 Bad request Your browser sent an invalid request " qui s'ouvre j'ai vidé l'historique supprimé les fichiers temporaires et toujours le même message. Avez vous été confronté au même message que moi ?

avez vous trouvé une solution ?

 

de plus depuis quelques temps le site apparaît chez moi en anglais suis je la seule ?

 

merci

Lien vers le commentaire
Partager sur d’autres sites

Bonjour Saida,

 

l'erreur 400, non, je ne crois pas avoir eu ça (des messages d'erreur, oui, mais alors c'est tout le site qui est inaccessible, pas un pb de lien).

 

Des indications en anglais, oui, j'ai repéré ça récemment : sur les dates des posts ("posté March 23") et sur la mention expanded ou condensed dans l'affichage de l'activité, des petites choses comme ça. C'est ponctuel et discret mais oui, il y a un petit mélange linguistique des affichages.

 

Mais bien sûr je n'ai pas l'explication !

Lien vers le commentaire
Partager sur d’autres sites

Bonjour, j'ai le même problème que vous en passant par Explorer....là avec Mozilla, aucun souci...le problème que je rencontre vient certainement du fait que nous avons une trrèèèèèsss ancienne version d'Explorer...donc j'arrive bien sur la page d'accueil du forum, mais ensuite impossible d'accéder aux discussions...il nous faudrait donc actualiser Explorer sur les postes pro du service public, mais ça, c'est une autre histoire...je lis donc le forum dans mon bureau :-)

Lien vers le commentaire
Partager sur d’autres sites

  • Administrateur

je viens de tester avec Explorer 11 (dernière version) : effectivement, il y a un gros soucis. la plupart des liens vers les sujets ne fonctionnent pas : erreur http 400.

je ne sais pas si c'est lié aux dernières mises à jour. je vais ouvrir un ticket avec le support.

par contre, aucun problème avec Chrome et Firefox.

 

cela dit et aussi pour info, Microsoft a arrêté tout support sur les anciennes versions d'Explorer : https://www.microsoft.com/en-us/WindowsForBusiness/End-of-IE-support

il est donc fortement conseillé de ne plus utiliser ces anciennes versions, et de toute façon, globalement, de ne pas du tout utiliser Explorer ;)

mais je sais que dans les collectivités, vous n'avez pas vraiment le choix :ermm:

 

et pour certains termes en anglais, il y a eu plusieurs mises à jour récemment et la traduction française n'a pas encore suivi. ça ne devrait pas tarder.

Lien vers le commentaire
Partager sur d’autres sites

Coucou,

Super que mon intervention aide mais moi  j'ai erreur 400 quand je me connecte avec mon smartphone mais en même temps j'ai un Windows phone est ce qu'il y aurait un lien cependant mon smartphone est à jour je viens de revérifier.

Mystère à demi résolu  ....

Merci pour les ouvertures de ticket auprès du support.:) 

Lien vers le commentaire
Partager sur d’autres sites

Le 14/6/2016 à 13:33, Rattigan Glumphoboo a dit :

pour certains termes en anglais, il y a eu plusieurs mises à jour récemment et la traduction française n'a pas encore suivi. ça ne devrait pas tarder.

ça, c'est fait ! merci Grand Modo.

 

@Saida : tant que ça ne fonctionne pas avec IE 11, ça ne risque pas de fonctionner avec ton windowsphone, même à jour. La joie des tickets...

 

Pour le moment, agorabib reste windows-incompatible. Ou l'inverse :ermm:

Pas de quoi jeter son téléphone par la fenêtre, quoique :devil:

Modifié par Isalabib
Lien vers le commentaire
Partager sur d’autres sites

  • Administrateur

la traduction française de la dernière version est sortie hier, je l'ai installée. donc effectivement, c'est réglé.

 

pour le problème des liens, c'est plus épineux.

attention, ça devient technique :

d'après IPS (la boite qui développe l'outil utilisé pour ce forum), le problème proviendrait de l'hébergeur (OVH). je vais donc contacter OVH.

mais je sens que chacun va se renvoyer la balle, comme d'habitude.

en fait, le problème vient des caractères accentués dans l'URL, situés après le point d'interrogation (utilisé normalement pour le passage de paramètres en $_GET en PHP).

en faisant un test avec mon serveur local, les URL problématiques passent sans aucun problème avec Explorer. par contre, sur le serveur d'hébergement OVH, ça coince.

cela pourrait donc bien venir d'une configuration des serveurs d'OVH. à confirmer.

mais tout de même, on ne laisse normalement jamais de caractères accentués dans une URL. il y a des fonctions pour encoder les caractères accentués et éviter ce genre de problème. donc là, c'est de la responsabilité d'IPS (ce sont des américains, évidemment ils ne connaissent pas les caractères accentués... ).

je sens que je vais passer de bon moments entre OVH et IPS :ermm:

 

pour précision, agorabib est parfaitement compatible avec windows. mon poste est sous windows 10 depuis peu et avant, sous windows 7 pendant plusieurs années.

le problème en question sur certains sujets non accessibles est lié uniquement à Explorer, le navigateur Microsoft, livré avec windows.

avec Firefox et Chrome, aucun problème.

Lien vers le commentaire
Partager sur d’autres sites

Avec Opera aussi.  :tongue:

Et sur Windows XP.


 

Pour le problème, ça pourrait peut-être venir du "jeu de caractères" utilisé par le navigateur. (UTF8, Latin, autre ?)

Soit d'un côté, soit de l'autre.


 

Il faudrait que Saida nous dise sur quelle page (quelles adresses, elle a des soucis d'erreur 400).

Des erreurs 400, j'en ai eu aussi, mais je suis têtu face à la machine, je demande un rafraîchissement à chaque fois. Et ça passe quasi toujours, peut-être parce que la demande emprunte un autre chemin sur le Net. Les mystères du Web sont parfois impénétrables.

  Bernard


 

P.S. : Allez, je viens de tester avec mon ancienne version Explorer 6.0, et j'arrive sur l'agora. En version dégradée, certes mais j'y arrive.
 

Lien vers le commentaire
Partager sur d’autres sites

  • Administrateur

bon, le problème est normalement réglé :)

j'ai pu modifier les options d'url rewriting. "index.php?" n'apparait plus dans les URLs, donc elle sont décodées sans problème avec Explorer.

j'ai fait l'essai sur mon poste et ça fonctionne.

Saida, tu peux me dire si ça marche de ton côté maintenant ?

Lien vers le commentaire
Partager sur d’autres sites

Il y a 19 heures, Rattigan Glumphoboo a dit :

bon, le problème est normalement réglé :)

j'ai pu modifier les options d'url rewriting. "index.php?" n'apparait plus dans les URLs, donc elle sont décodées sans problème avec Explorer.

j'ai fait l'essai sur mon poste et ça fonctionne.

Saida, tu peux me dire si ça marche de ton côté maintenant ?

Bonjour

magnifique les liens fonctionnent merci pour la rapidité de résolution et

le français et de retour par la même occasion super.

bon il ne manque plus que le soleil lol

bon j'ai plein de sujet à lire cette erreur ma mise en retard .... ;)

 

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Restaurer la mise en forme

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

×
×
  • Créer...